Import-Module : Could not load file or assembly 'System.Data.SQLite,

Feb 10, 2013 at 7:56 PM
hi
imtrying to import the module in a server windows 2008 r2 , and i getting the following error.
using the same module in my win7 it works ok
any ideas?


PS C:\Users\Administrator> Import-Module sqlite
Import-Module : Could not load file or assembly 'System.Data.SQLite, Version=1.0.77.0, Culture=neutral, PublicKeyToken=db937bc2d44ff139' or one of its dependencies. The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log or use the command-line sxstrace.exe tool for more detail. (Exception from HRESULT: 0x800736B1)
At C:\Windows\system32\WindowsPowerShell\v1.0\Modules\sqlite\start-sqlite.psm1:83 char:39
  • ls $PSScriptRoot/bin/x64/*.dll | ipmo <<<< ;
    • CategoryInfo : NotSpecified: (:) [Import-Module], FileLoadException
    • FullyQualifiedErrorId : System.IO.FileLoadException,Microsoft.PowerShell.Commands.ImportModuleCommand
Coordinator
Feb 11, 2013 at 1:24 PM
Any chance you may have forgotten to unblock the zip file before extracting the module?

What's the value of $psversiontable on your 2008r2?
Feb 11, 2013 at 5:25 PM
Hi
Thanks for the rapid answer.
About the unzip , i tryied extractracting the downloaded module files, also , copied the module folder from my WIN7 , where is perfectly working.

the error ocurr , when trying to load the dlls at x64 (ls $PSScriptRoot/bin/x64/*.dll | ipmo;)

output of $psversiontable

Name Value

CLRVersion 2.0.50727.5420
BuildVersion 6.1.7601.17514
PSVersion 2.0
WSManStackVersion 2.0
PSCompatibleVersions {1.0, 2.0}
SerializationVersion 1.1.0.1
PSRemotingProtocolVersion 2.1

Also i ve instaled .NET 4.0.
there are any prequisites?
thanks